RocPro3D - Release 5.7.12 (64 bits version) - (20/03/2024)
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1) Network license
- Removal of the network license option (previous versions are no longer working since
March 6th 2024).
- The following menus are thus disabled from the UI
* Tools->Network configuration
* Tools->Network access authorized
* Tools->Save autorization info
* Help->Register RocPro3D
- The network license is replaced by a new licensing system.
The installation procedure is described in the file 'install guide.pdf' provided with
the setup file.
- This update is thus mandatory to keep version 5 working.

RocPro3D - Release 5.7.11 - (22/06/2022)
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1) Protections
- Improved calculation of the intersection of some portions of sliding/rolling trajectories.

2) Export of discretized trajectories (*.traj file)
- Corrections of discretized trajectories that are now expressed in global coordinates.

RocPro3D - Release 5.7.10 - (13/02/2022)
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1) Massive computation strategy
- When performing calculations with a very large number of blocks (e.g. in a massive
computation strategy), the application could freeze. This issue is now fixed.

2) Modification of the density envelope display unit

- In previous version (i.e. up to 5.7.9), the density envelope (i.e. traj density envelope)
was expressed in $traj/cell.

- From now, it is expressed in %$traj/m2 to be independent of the grid cell size.

RocPro3D - Release 5.7.9 - (10/11/2021)
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1) Export of discretized trajectories

- In addition to the possibility to export the profile of an individual trajectory for the
selected block on a *.ptraj file (already available in previous versions), it is now
possible
to export all discretized trajectories (with respect to time) on a ascii *.traj file (see
the
corresponding check box in the "Preferences definition" dialog).

2) Correction of sliding trajectories on horizontal faces
- In the case of portions of sliding/rolling trajectories on strictly horizontal faces, the
interaction with the protections could be incorrect. This problem is now corrected.

RocPro3D - Release 5.7.8 - (12/03/2021)
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1) Reading UTF-8 BOM encoded files
- Correction made to reading text files using the UTF-8 BOM encoding, which could lead to
a crash of the application. This issue is now fixed.



RocPro3D - Release 5.7.7 - (26/11/2020)
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1) Corrections on DTM edition

- During the removal operation of unused points isolés (cf. dialog "Edition of the DTM"),
existing sources and protections were modified (translation). This is now fixed.

- Operations of DTM noise or smoothing can now only be carried out on a mesh that does not
have unused point. If this is the case, a message warns the user.

RocPro3D - Release 5.7.6 - (11/10/2020)
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1) Import of DTM
- When importing a DTM with overhanging or inverted faces, the number of overhanging or
inverted faces indicated in the corresponding dialog box was incorrect. This is now fixed.

RocPro3D - Release 5.7.5 - (24/08/2020)
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1) Updates
- Update of the library Fox-1.7.60 to Fox-1.7.71.

2) License
- Removal of the hardware license.

3) Bug fix in the calculation of the intersection of the trajectories with the protections:

- For the portions of trajectories (i.e. in 2D for each segment separating 2 impacts) which
intersect a net protection and intersect the DTM boundary, a bug produced the apparent
stopping of the trajectory by the net, regardless of its capacity. The problem was visible
in the 2D, 3D and Profile views of the trajectories. This issue is now fixed.

- Note : The analysis of the trajectories on the protections was nevertheless correct.

4) Correction of the display of the selected trajectory ("Analysis" tab)

- When the trajectory of a block was selected in the 2D view ("Analysis" tab), a bug could
occur 1in rare cases, which led to an erroneous display of the profile of this trajectory
in the 3D, Profile and Graphs view of the trajectories. This issue is now fixed.

- Note : the trajectory computed for this block was nevertheless correct.

5) Creation of surface sources
- When creating a surface source by closing a pre-existing lineic source (2D view), the
created source did not have the surfacic type. This issue is now fixed.

6) Improvements of topo backgrounds import under tif format
- After importing some images (topo background) with tif format, they could appear as being
reflected with respect to the x-axis. This issue is now fixed.

RocPro3D - Release 5.7.4 - (13/08/2019)
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1) Correction to reading files of points
- Importing points files using the coma or semi-column as numbers delimiter (csv type) was
producing the closure of the software. This issue is now corrected.

2) Reading UTF-8 BOM encoded files
- Text files using the UTF-8 BOM encoding can now be imported.

RocPro3D - Release 5.7.3 - (01/05/2019)
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1) Meshing of raster DTM

- Mesh creation of the raster DTM (.dem and ESRI .asc) 1is greatly optimized in terms of speed
and also in terms of quality of the produced mesh (only regular faces are now created,
whereas this was not the case with previous versions).

- This optimization requires to create the mesh directly after importing the DTM.

2) Blocks sources settings

- The ranges of values (Min,Max) resulting from user-specified variations of parameters
(probabilistic computations) have been added to the "Sources settings" dialog (for
information only), to make their use easier.

3) File .stat
- For each protection, addition on the file of
* its 2D geometry,
* the min and max values of the blocks mass and volume that reach or fly over the
protection.

4) Properties of the selected protection
- In the dialog "Protection statistics", addition of
* min and max values of mass and volume for blocks that reach or pass over the protection.

RocPro3D - Release 5.7.2 - (15/03/2019)
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1) Envelopes
- The export of the min time envelope was not working. This is now corrected.

RocPro3D - Release 5.7.1 - (05/02/2019)
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1) Hardware license
- The hardware license is reactivated in the corresponding dialog box (it was desactivated in
version 5.7.0).

2) Changing the face selection dialog ("Soils" tab)
- It is now possible to enter real numbers (previously only numbers integers) in the fields
of the different face selection filters.

RocPro3D - Release 5.7.0 - (06/12/2018)
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1) File .stat (statistics on protections)
- When exporting the .stat file for a given protection (tab Analysis > Protection), it is
now possible to change the name proposed by default via a dialog box.

2) Improvements of writing formats on ascii files

- Various ascii files (.stat, .prot, .cell) are available to allow possible exploitation of
the results of RocPro3D calculations in third party softwares.

- The formats of these files have been improved (adding tabs) to facilitate their import,
e.g. in Excel.

3) Hardware license
- The hardware license being no longer used since version 5.3.0 (in favour of the network
license), this option is now disabled in the corresponding dialog box.

4) Correction on DIM edition (translation)
- Among the different geometric transformations that can be applied to a DTM (see dialog
"Edit DTM"), the translation had an error, which is now corrected.

5) Incomplete trajectories
- Reduction of the number of incomplete trajectories.
- Deletion of irrelevant informative messages on the log file.



RocPro3D - Release 5.6.4 - (14/07/2018)
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1) Sources
- For sources with falling height initial condition, the default block density of 2500 kg/m3
was always taken into account when reading back projects. This is now fixed.

2) Removal of sources or protections

- When a source (or a protection) was removed from the dialog box "Blocks sources settings"
(or "Protections settings"), the previous source (or protection) properties were modified.
This is now fixed.

RocPro3D - Release 5.6.3 - (17/05/2018)
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1) Protections

- Improvement of the case where several successive protections were defined in a slope, which
could erroneously allow blocks to pass through some downstream protections. This is now
fixed.

RocPro3D - Release 5.6.2 - (22/02/2018)
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1) View of the profiles of trajectories
- When analyzing a trajectory profile (2D profiles view), the position of protections could
appear with a downward offset. This is fixed.

RocPro3D - Release 5.6.1 - (16/02/2018)

RO R g I b b Sb b S db b b dh Sb b S S b b S S b db dh I b S Sb b b db b b S db b db Ib b S db b S db b b db Ib b i db b b I b

1) Soil properties

- In the user manual, the soil parameters table contained an error on the line of friction
coefficients, which were reversed. The manual is now corrected and it is consistent with
the default soil properties provided in RocPro3D.

2) Protections

- When several successive protections were defined in a slope, it could happen, for some
trajectories, that the calculations of interaction between these trajectories and the
protections erroneously allow blocks to pass through some downstream protections. This
is now fixed.

RocPro3D - Release 5.6.0 - (19/11/2017)
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1) Saving on image file of the envelopes
- Saving the image file of the impact map could lead to a crash of the application. This is
now fixed.

2) Reference point of the height of the blocks
- There were some inconsistencies in previous versions

* For 3D height envelopes, for protection statistics (files *.stat), and for the position
of the blocks in the profile view, the heights taken into account corresponded to the
height of the reference point considered for the blocks (default to the middle point),
such as defined in the dialog "Computation settings".

* For the 2D profiles view of protections, the height wvalues reported in the color scale
always considered the height of the bottom point of the blocks. Similarly for the view
of histograms.

- These inconsistencies are now corrected
* The height of the blocks corresponds in all views to the reference point considered for



the blocks, such as defined in the dialog "Computation settings™".
- Note about older projects
* When opening projects created with previous versions (up to 5.4.1), these inconsistencies
are also corrected with the present version. It is thus unnecessary to compute again
trajectories for these projects.

RocPro3D - Release 5.5.0 - (10/09/2017)
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1) Updates
- Update of the library Fox-1.7.57 to Fox-1.7.60.

2) User interface (UI)

- Three new fields have been added to the status bar (at the bottom of the main window), to
the right of the Cell(i,j,val) label.

- When an envelope is displayed in the 3D view, these fields indicate respectively, for the
cell under the cursor:

* The (i,Jj) index of the grid cell,

* The value (val) of this cell for the map being displayed.

- Moreover, when the "Selection" tool is active AND the Ctrl key is kept pressed, a left
mouse click on a grid cell:

* Select this cell which then becomes overlined,

* Allow to visualize in the Graph View, for energy, velocity and height, the full data of
this cell's population, as a histogram. This vizualisation is only possible for advanced
envelopes.

Note:

These 2 functionalities already existed in previous releases of RocPro3D, but it was
then not required to hold the Ctrl key pressed while performing the left click.

* Opens up a dialog providing all values of interest about this cell, i.e. energy, velocity,
height, energy classes, density, minimum time...

3) Envelopes

- Fixed a bug that could produce in rare cases during the computation of the envelopes,
and which could lead to the crash of the application.

- For new projects, the full (i.e. advanced) envelopes are now the default option
(previously it was the simple envelopes).

- In the case of the classic computing strategy, calculated envelopes are now saved. This
avoids having to recalculate them at the reopening of an old project.

4) Addition of raw results export options
- To allow the user to access the raw results of the calculation, the user can now choose
whether or not (see Menu Tools->Preferences) to export to ascii format for:
* Data of protections (file .prot),
* Data of grid cells (file .cell) that are used to calculate the different analysis maps.
- These 2 options are disabled by default, because it can result in large files in the case
of projects for which a significant number of trajectories is calculated.

RocPro3D - Release 5.4.1 - (03/05/2017)
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1) Sliding/rolling trajectories

- Correction of the formulation to handle the case where the limit velocity is reached (i.e.
when the friction coefficient is equal to the tangent of the slope and that this slope
is constant over long portions of the trajectory profile).

- In practice, this case was rarely encountered for 3D DTM.

2) Correction of a bug in case of an erroneous hardware license

- In case of an erroneous hardware license, a bug was leading to closure of the application.
This is now corrected.

3) Modification of the protection for perpetual hardware licenses
- When no network is available

* Perpetual hardware licenses remain valid,

* Their maintenance date is however not available.

4) User interface
- Keys + and - produce the same behaviour as the buttons + and - of the UI in the "Run" tab.



RocPro3D - Release 5.4.0 - (18/03/2017)
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1) Addition of options for connecting to www.rocpro3d.com server

- A dialogue has been added via the menu "Tools" -> "Network configuration", which allows to
specify different configuration options for accessing to the server
* Proxy,

* Proxyport,

and in case of a proxy requiring an authentication
* Login,

e Pwd.

2) Modification of the menu "Help"

- The sub-menu "Register RocPro3D" has been modified, to allow choosing between the hardware
license and the network license.

- The sub-menu "Test of the connection" has been removed from the menu "Help", this
functionality being moved into the menu "Tools" -> "Network configuration" wvia the
corresponding button.

3) Correction for file writing on protected directories

- Saving or removing files located in directories for which the user does not have write
access (e.g. sub-direcories of "C:\Program Files") could lead to abnormal termination
of the application. This bug is now corrected.

RocPro3D - Release 5.3.2 - (14/02/2017)
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1) Correction for reading files defining topography
- During import of files asc, csv, xyz, txt and ply, names with special characters could
prevent to read the file. This is now corrected.

2) Modification of the network connection option to server www.rocpro3d.com
- This option is now deactivated by default.
- It should be activated to allow network registration (network lock).

RocPro3D - Release 5.3.1 - (13/01/2017)
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1) Updates
- Update of the library Fox-1.7.56 to Fox-1.7.57.

2) Correction of surfacic sources
- In case of a surfacic source containing 3 points (i.e. with nil area), the probabilistic
computation could lead to crash of RocPro3D. This is now corrected.

3) Correction of the creation of a new soil
- The "Create new soil" option produced a possible crash of RocPro3D. This is now corrected.

4) Addition of network connections options to the server www.rocpro3d.com

- The verification of the existence of updates and the management of the network keys require
that the application can access the server www.rocpro3d.com.

- In some cases, network access may be restricted for security reasons (e.g. using a
firewall), and therefore may not allow the operations mentioned above.

- It may be useful in this case to disable network access, which allows RocPro3D to launch
faster.

- This deactivation/activation is done in the "Tools" menu, by the check box "Network access
authorized"

5) Addition of a dialog on the connection
- Addition of a dialog when launching RocPro3D, which provides the current connection info

at the server www.rocpro3d.com.

6) Addition of a test on the connexion to the server www.rocpro3d.com



- In the "Help" Menu, the possibility to test the connection to the server www.rocpro3d.com
has been added.

RocPro3D - Release 5.3.0 - (12/08/2016)
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1) Time stamp
- Time stamping bloc and summ files.

2) Addition of a new possibility for registering license
- Hardware registration (hardware lock):
Until the previous version (5.2.1), registering RocPro3D could only be done on the basis of
an activation key specific to each hardware configuration.
- Network registration (network lock):
From this version (5.3.0), it is now possible to use a new registration method, provided an
internet connection is available and active. This method offers new possibilities by
combining:
1) Identification of a minimum one of the following items:
* Hardware configuration,
or
* DNS domain name and possibly Username.
And
2) A check of the following additional criteria:
* Expiration date,
* Main version accessible,
* Type of license (or professional education).
- Each time RocPro3D is launched, identification is verified and additional criteria are
tested.
- The license information is summarized in the dialog "About RocPro3D".

RocPro3D - Release 5.2.1 - (25/06/2016)
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1) Corrections applied to xy positionning of
- Envelopes exported as raster (asc) files.
- Density isolines exported as dxf files.

RocPro3D - Release 5.2.0 - (18/06/2016)
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1) Updates
- Update of the library Fox-1.7.37 to Fox-1.7.56.

2) Meshing

- Correction to take into account utf file names.

- Addition of an extra method to scale the map : it is now possible to specify co-ordinates
of the first point and the distance to second point.

- On DTM import (of type DEM or asc), a dialog allows to restrict imported points to a
specified zone (xmin, xmax, ymin, ymax, zmin, zmax). This allows, amongst other, to avoid
importing unrealistic points that can sometimes exist in DTM data.

- The button "Import image" in the DTM tab remains active, which allows changing the
background image mapped onto the DTM (or removing the current image).

3) Level curves
- Correction made to the memory management of closed level curves.
- Correction of a test on closed lines.

4) User interface (UI)

- The + and - keys produce the same actions as buttons + and - of the UI.
- Removal of the 3D view reset upon insertion of a topo point.

- Correction of a bug related to update of soil name.

- Vizualisation of block mass of the selected trajectory (tab "Traj").

5) Removal of Sources and Protections



- Addition of a "Removal" button in dialogbox of source and protections settings, allowing
to remove the current objet (source or protection). This button is active only if there
are more more than one source or protection.

6) Trajectory export
- Addition of stopping points export in the dxf file.
- Addition of the mass of each block in the exported trajectory file (*.traj).

7) Envelopes

- Addition of an extra envelope (NumTraj), representing the number of blocks that cross each
cell.

8) File *.summ (ascii)
- Addition of properties of soils, sources and protections for the computed simulation.

RocPro3D - Release 5.1.3 - (25/09/2014)
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1) DTM import
- Addition of the possibility to import DTM with the format ESRI Ascii (altitude raster grid).

RocPro3D - Release 5.1.2 - (04/04/2014)
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1) Envelope file reading/writing
- For the specific case of massive computation, several fixes have been applied to the I/0 of
envelopes file (*.gpda). These corrections follow the addition of raster based envelopes,
introduced in version 5.1.0. This now allows to:
* Save projects having envelopes with different values for Nx and Ny,
* Read projects containing envelopes created with previous RocPro3D versions (up to
version 5.0.4).

RocPro3D - Release 5.1.1 - (25/03/2014)
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1) Registration
- Correction of a bug that could make it impossible, in some rare cases, to register the
software.

2) Protections (multithread computation)
- Sort the impacts of each Protection in Id ascending order (if needed, makes easier the
comparison with singlethread computation results).

RocPro3D - Release 5.1.0 - (05/03/2014)
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1) Modified links (update link, web help)
- To account for the web site modification (now at www.rocpro3d.com).

2) DTM import

- Added import of file points as xyz format (only the coordinates of points, without
their normal).

- Added tests of imported meshes quality on:
* The mesh "manifoldness"
* The mesh connectivity

3) DIM edition
- Added three options (block "Verify/correct the mesh")
* Removal unused points.
* Imposition of normal of all faces upward.
* Remove overhanging faces (and unused points, if applicable).



- Improved decimation option of an existing mesh.
- Added many MessageBoxes informing on result of the performed DTM editing operation.

4) Mesh export to stl file:
- Export the mesh to a stl file did not work properly for file paths containing special
characters.

5) Select faces by dip

- Correction of Pi/2 to be consistent with the classical definition of dip
(0°=horizontal, 90°=vertical).

- Fixed iterator indicating the number of selected faces.

6) Removal of selected faces
- Deleting the selected faces (see button in the Topo tab area "Selecting faces"™) did not
work in the case of newly created projects.

7) Filter on trajectories
- Fixed filter on sources when there were more than 10 sources (source actually selected
could then be erroneous).

8) Grid of envelopes
- In the previous versions of RocPro3D, envelopes were defined exclusively by a number of
cells according to the 2 directions (Nx, Ny).
- It is now possible (optional) to define a raster-like grid envelope, i.e. based on square
cells defined by their length (Lx).
- Thus, when exporting an envelope, the following files are saved
* For conventional envelopes (i.e. non-square cells)
- *.envl file (data)
- *.png file (image)
* For envelopes raster type ( square cells )
- *.envl file (data)
- *.png file (image)
- *.,asc file (ESRI Ascii raster format), which can be easily imported into GIS (e.g.
ArcGIS)

9) Envelope settings dialog
- Fixed a bug that could lead to the termination of the application when displaying
the dialog.

RocPro3D - Release 5.0.4 - (02/10/2013)
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1) User interface

- The buttons "Define filters" and "Protection statistics" ("Protections" tab in the
"Analysis" tab) are now colored, to make it more obvious that the user can click on these
buttons.

2) Modification of the selection of faces
- The selection of faces is now possible even if no soil has been defined yet.

3) Correction of displayed values during selection of faces by ranges

- Upon opening of the dialog for selecting faces by ranges ("Soil" tab), displayed values
in the field of the zone "Coordinates range" (XMin, YMin, XMax, YMax) could be not to date
(the Reset button could allow to update them). This is corrected.

4) Correction of the "Geometry scaling" transformation applied to the DTM
- The case of level curves was not correctly treated.
- The viewpoint of the 3D view is now updated.

5) Correction of the image file name
- The image file name (saved in the file .rpro) could be incomplete in some rare cases.

6) Correction of protections settings

- When a protection was selected, and afterwards the dialog "Protection settings" was open,
the displayed parameters for this protection could than not relfect the real parameters.
Note : This problem did not occur when the dialog was open without any selected protection.

7) Correction of filters on the selected protection
- For the "Massive" computation mode, filters applied on the selected protection were not
working correctly (all values were excluded, which resulted in no data displayed).



RocPro3D - Release 5.0.3 - (05/09/2013)
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1) Fix on reading the binary .bloc file
- Small correction applied for reading the binary .bloc file, which could induce a bug with
the 32 bits version (termination of RocPro3D) when the file had 0 blocks.

2) Correction of a web link
- In the dialog "About RocPro3D", the link to the RocPro3D web page was no longer up to date.

RocPro3D - Release 5.0.2 - (05/04/2013)
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1) Updates
- Upgrade the Vtk library from vtk-5.10.0 to vtk-5.10.1

2) Structured meshes
- Correction for the generation of some structured meshes, which could exhibit all faces with
inverted normals.

3) Graphical output on image files
- Correction of colors (permutation of red<->blue chanels) for images files obtained with
the button "Print the active view on an image file" (png extension).

RocPro3D - Release 5.0.1 - (26/11/2012)
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1) Updates:
- Upgrade the Fox library from Fox-1.7.36 to Fox-1.7.37

2) Compatibility of RocpPro3D-64-bit with Windows 8-64 bit:

- In its previous 64-bit version (RocPro3D x64 5.0.0), RocPro3D was not compatible with
Windows 8 64-bit version.

- From this release, RocPro3D x64 is compatible with the 64-bit version of Windows 8 (thanks
to a correction of the 64-bit memory addressing made to the Fox library Toolkit).

3) Launching RocPro3D:

- In addition to the classical launching of RocPro3D (icon or taskbar shortcut on the
desktop), the double click on a *.rpro file (e.g. in the Windows Explorer) launches RocPro3D
and also opens the corresponding project.

4) Project Menu:
- The number of recent projects stored (see menu "Project->Recent...") 1is increased from 10
to 20.

5) Web link update:
- Fixed the htpp link for updating new versions of RocPro3D.

6) Edition of imported DTM:
- Added a filter to smooth the mesh of a DTM (cf. dialog "DTM Edition") taking into account
(or not) the border and/or edges nodes.

RocPro3D - Release 5.0.0 - (01/10/2012)
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1) Updates:

- Upgrade of VC++9.0 to VC++10.0

- Upgrade the Fox library from Fox-1.7.32 to Fox-1.7.36
- Upgrade the Vtk library from vtk-5.6.1 to vtk-5.10.0



2) Changes to the output files (extensions and contents):
- File *.rpro (project):

* The project file now has the extension *.rpro (replaces the old fem file)

* It contains some data (sources, protection, soil properties calculations envelopes)
of the old PiR3D Fem files, although with the following differences:

e Addition of the number of each soil and each protection
e Addition of data specific to the rigid block formulation (see point 6)
* It does not contain anymore:

- The mesh (topography and topology), now saved on the file *.mesh.

- Trajectories blocks, now recorded on the file *.bloc.

* The old project files (fem) of PiR3D can still be replayed (select the file type
*.fem in the "Open Project" dialog). Changes in these old projects cannot be saved,
however, as the new format (*.rpro).

- File *.mesh (ascii or binary):
* Contains topography (topo points, contours, geological points and lines) and topology
(definition of mesh faces).
- File *.block (ascii or binary):
* Contains the computed trajectories.
- File *.stat (ascii):
* New file containing tables of summary statistics for each protection for:
* all trajectories intercepted or passing over the protection,
* trajectories intercepted by the protection,
* trajectories passing over protection.

* For each variable (E, Etr, Erot, Vtr, Vrot, Height, Time), the following parameters are

given: N, Min, Max, Mean, StDev, LC99, LC95, LC90, LC68, Q95, 090, 080 and Q50.
- File *.traj (ascii): profile of the selected trajectory

(
- File *.summ (ascii): summary of calculation made
- File *.prot (ascii): data protection impacts on (only for classic strategy)
- File *.envl (ascii): export of an envelope data
- File *.gpda (binary): grid envelopes (only for massive computation)
- File *.vimp (binary): data protection impacts on protections (only for massive computation)

- Dxf File: Adding of sources (in addition to protections) in the DXF export of trajectories.

3) Improved random number generator:

- The C++ function rand(), previously used to generate random numbers, has been replaced by
an algorithm allowing to generate random numbers with a period of 1.84el9.

This algorithm is adapted from "Marsaglia G., Random number generators, Journal of Modern
Applied Statistical Methods 2, No. 2, 2003".

- Consequently, the probabilistic calculations made the "pseudo-random" option with previous
versions (up to PiR3D wv4.1.5) will not produce the same results when they will be re-run
with RocPro3D.

- The use of this new random number generator now allows to perform "true random" or
"pseudo-random" parallel computations.

4) New meshing options:
- Models of 2D type:

* Models created from a 2D profile can be transformed into a DTM type model (see button
2D->3D in the "2D profile" sub-tab of the "Topo" tab).

* This is then used to perform all editing operations available for DTM type models,
especially resampling and adding a noise effect (see below).

- DTM type models:

* Addition of buttons to create topo points or contours.

- Mesh noising of DTM type models (see "DTM Edition" dialog):

* For DTM type Mesh, it is now possible to add a noise to the DTM in the "DTM Edition"
dialog.

* This noising consists to alter the Z coordinate (elevation) of the mesh points by
applying a variation. This noise is defined by a random variation (-dz,+dz) or Gaussian
(centered standard deviation sig z) around its original value.

* The noise is applied to all grid points falling within the selection area (shown by the
red rectangle in the 2D view), thus allowing to apply when necessary various noises to
different areas.

* The application of a noise can, amongst others, be useful in the study of theoretical
2D profiles for which a survey is not available.

5) Computation of trajectories:
- Optimization of the computation, resulting in a computation time divided by approximately 2
compared to the previous version (4.1.5 PiR3D).
- Fix to the cancellation of trajectory computation:
* In previous versions, stopping a multithreaded computation (by clicking on the "Cancel"
button) could produce a bug leading to the termination of the application,
* This bug is now fixed.

6) Addition of a Rigid Block type formulation:



- Up to version 4.1.5 (PiR3D), the trajectories of blocks were calculated from a Lumped Mass
physical formulation.

- From this version (RocPro3D 5.0), it is possible to use a physical model based on Rigid
Block formulation. This allows taking into account the shape of the blocks and the effects
associated to their rotation (angular speed and inertia) for the portions of trajectories
in rolling and impact.

- In summary, compared to earlier versions (see the User Manual for more details):

* Portions of "flying" trajectories are not modified (the effect of blocks rotational
velocity on the flight portion is neglected).

* The portions of trajectories rolling on the DTM are modified (previously it was a sliding
that was taken into account) as they take into account the rotational velocity and blocks
inertia by combining:

* an assumption of rolling without sliding,
* a dynamic rolling friction.
* The physical model of impacts is also changed:
* a portion of the rotational energy is dissipated at impacts,
* the Rt coefficient depends on the incident rotational speed, on the block mass and on
the block inertia.

- Notes:

* The type of formulation lies in the "Properties calculations™ (see the dropdown list
"Formulation”™ in the "Type of simulation” area).

* By default:

* New projects are created by default with the Rigid Block type formulation
* When projects created with earlier versions are read, the Lumped Mass formulation is
selected by default.

7) Soil parameters:
- The default values of the coefficients of friction (sliding for the Lumped Mass formulation;
rolling for the Rigid Block formulation) for the different soil types are slightly modified
as follows (previously k = 0.6 for all soils):
* loose soil k = 0.60 (friction angle = 30.96°)
* loose debris .60 (friction angle = 30.96°)
* compact debris .55 (friction angle = 28.81°)
* altered rock .50 (friction angle = 26.57°)
» sane rock .45 (friction angle = 24.23°)
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8) Addition of dynamic graphs:

- To facilitate the modification of probabilistic soil parameters, of the dissipative model
or the choice of the envelope statistical parameter, several dynamic graphs have been
added in the following dialogs:

* "Soil properties":
Histograms and graphs dEps (V) for each soil parameter Rn, Rt, lateral and vertical
deviation, k. The graphics are updated automatically from values specified in the various
input fields (numeric values and chosen type of probabilistic variables).
* "Computation properties":
Graph Rn (V), updated according to the chosen model (classic or velocity dependent Rn) and
to the parameter K.
* "Envelopes properties™":
For a given population, display of the histogram, empirical and theoretical (assuming
normal distribution) cumulated frequency curves, and display of the statistical chosen
parameter position for the envelope:
* Red dot on the adequate cumulative curve (empirical for Max and KS-d, theoretical for
Mean and CL)
* Red segment (KS-d and KS-p) whose length corresponds to the value of KS-d, positioned
between the empirical and theoretical cumulative frequency curves.

- Note: the display of graphics in the dialog is enabled by default. To disable it, go to

the menu "Settings" and uncheck the corresponding checkbox.

9) Choice of the reference point for heights of blocks trajectories:
- In the previous versions (PiR3D), the center of mass (CoM) of the blocks was considered
as a reference point for heights of trajectories:
* The height data can be viewed in the different analysis tools: visualization of
trajectories, of impacts on protections, of envelopes.
* The height of the blocks is also used to calculate the interaction with the protections,
in particular to determine if the blocks reach the protections or pass over.
- It is now possible in RocPro3D to choose the reference point for calculating trajectories
(by default CoM), their interaction with the protections and envelopes (high) among
the following five possibilities:
* Low: point corresponding to the lowest point of the block,
e 1/3: point located at 1/3 of the diameter of the block (from the bottom)
* CoM: point corresponding to the center of mass of the block (0.5 diameter),
* 2/3: point located at 2/3 of the diameter of the block (from the bottom)
* High: the point corresponding to the highest point of the block (one diameter from the



lowest point).
- The choice of the reference point is available in the dialog "Properties calculations"
(see drop-down list in the zone "height trajectories").

10) Sources of blocks:

- When opening the dialog to define "Sources settings", data of the selected source are
displayed, or data of the first source if none is selected in the 2D view.

- As long as a calculation has not been performed, it is possible to edit the coordinates
of the sources (see table in "Properties of sources"), which allows placing the sources
of blocks at exactly the desired position (a priori useful for 2D profile-type models).

- It is possible to import the geometry of a source from an ascii file (see button in
the zone "Sources" of the tab "Run").

- The information on length/area of sources are displayed in the "Sources settings"

- The density of the blocks (set to 2500 kg/m3 in the previous versions) can be changed.

- With the Lumped-Mass formulation:

* Only blocks with spherical shape are possible. As in previous PiR3D versions, their
mass 1is used in the calculation of energy and their size is only taken into account
via the height of the reference point of the block (center of mass by default) relative
to the ground.

- With the Rigid Block formulation:

* It is possible to choose between two types of blocks (sphere or disk). Their mass,
inertia and velocity are taken into account in the calculations of the trajectory.

e If initial conditions are specified in terms of absolute velocity, it is necessary
to define the initial translational and rotational velocities. This allows for example
to start blocks in flight with independent initial translational and rotational
velocities.

e If initial conditions are specified in terms of velocity relative to the faces slope,
the initial velocity norm (tangent to the dip direction) must be defined. The initial
rotational velocity w is then calculated automatically from w=|V|/R, where R is the
block radius.

e If initial conditions are specified in terms of falling height, initial rotational
velocity is zero (such as translational velocity).

* Note: In the "Blocks sources settings" dialog, the input field for initial rotational
velocity is not displayed when the Lumped-Mass formulation is selected.

11) Protections:

- When opening the dialog to define "Protections settings", data of the selected protection
are displayed, or data of the first protection if none is selected in the 2D view.

- Ability to import geometry of protection from an ascii file (see button in the "Protection"
block of the "Run" tab).

- As long as a calculation has not been carried out, it is possible to edit coordinates of
protection points (see table in the "Properties protections" dialog), which allows placing
the protections exactly at the desired position (a priori useful for 2D profile-type
models) .

- Information on the protection length is displayed in the "Protections settings" dialog.

- The orientation sense of a protection can now be reversed (cf. corresponding button
in the "Protections settings" dialog). This allow setting all protections in the same
direction relative to the slope, making it more uniform and facilitating the interpretation
of the protections view profiles.

- Improvements to the intersection method of sliding/rolling trajectories portions with
protection:
up to version 4.1.5, when the protections included several segments, some intersections
could (in some rare cases) not be calculated due to numerical approximations. A correction
is made to properly handle these cases.

- In addition to the standard NF P 95-308 old, the energy classification level of protection
kits as defined in ETAG 27 (MEL) is now available to facilitate the choice of type
protection net.

12) Analysis Tools:

- 3D View: View of the blocks geometry according to their shape (sphere, disk) if a trajectory
is selected and impacts are displayed.

- Analysis of trajectories:

* In the Profile view, in addition to the kinetic energy (total, translation, rotation) one
can also view the translational and rotational wvelocity, the blocks height (of the
reference point) above the DTM and the time (see choices in the drop-down list).

- Analysis of protectsions:

* In the protections Profile view, the same parameters as for trajectories Profiles can be
analyzed (i.e. E, Etr, Erot, Vtr, Vrot, Height, Time).

* In the Graph view (protection histogram), it is now possible to modify Min and Max of
histograms: cumulative curves are plotted considering statistics (Mean, StDev) over the
specified bounds.

* For the selected protection, it is possible to refine the analysis by applying three
filters (see button "filter" in the Protection tab):



e A filter to select sources taken into account for the protection analysis
A filter over the range of curvilinear coordinates taken into account in the protection
analysis
e A filter on the trajectories taken into account (all by default) in the protection
analysis (Profile and Graph views) and that are displayed in the 3D view:
- All trajectories (i.e. intercepted or passing over protection)
- Trajectories passing over the protection,
- Trajectories arriving in the protection,
- Trajectories stopped by the protection (i.e. whose capacity is < impact Energy),
- Trajectories through the protection (i.e. whose capacity is > impact Energy).
Notes:
* The Profile and Graph views (histogram) are updated based on the selected filters,
and only the filtered trajectories are displayed in the 3D view,
* For the envelope profiles along a protective, only the filter on the curvilinear
coordinates range is active,
* The filters on the type of trajectories and on the range of curvilinear coordinates
are specific to each protection,
* The filter on the sources is common to all protections.

* For the selected protection, it is possible to display the statistical summary (N, Min,
Max, Mean, StDhev, CL99, CL95, CL90, CL68, Q95, Q90, 080, Q50, KS-d, KS-p) of each
analyzed variable (E, Etr, Erot, Vtr, Vrot, Height, Time). This summary is displayed
as tables (see "Sigma" button in the Analysis->Protection tab) calculated by combining
the type of protection and the three filters specified in the Analysis->Protection tab
(see above).

Depending on the protection type, the following tables are displayed:

* 3 tables for the fictitious Protections: all, above, through

* 5 for Nets: all, above, reaching, stopped, through

* 3 tables for Embankments: all, above, stopped

Notes:

e Data tables (with their headers and associated titles) can be exported to an ascii
file (see button on the right side of the dialog).

13) Envelopes:

Addition of the envelope of minimum travel time (only the Min value is available,
so Max, Mean, Quantile, CL and KS statistics are not available).

14) Addition of a statistical test (Kolmogorov-Smirnov)

For advanced envelopes, it 1s possible to calculate the parameters (d distance and
p-value, ranging between 0 and 1) of the Kolmogorov-Smirnov statistical test, with the
hypothesis (HO) of a normal distribution for the population of each grid cell:

* The maximum distance d measured from the sample / to the theoretical sample normal law,
* The p-value represents the probability that the distance is > d with HO true.

The examination of these two parameters (in particular the high d values and low p-values)
allows detecting the envelope cells for which the normality assumption is rejected, and
for which the chosen statistical parameter should be chosen with caution for their
analysis. Indeed, in these cases, the confidence intervals (also calculated with an
assumption of normality) are no longer relevant sensu stricto, and it may be preferable
to use quantiles (as calculated without assuming that the distribution parameter follows
a given probability).

To view one of these two statistical parameters (d distance or p-value), one must select
the corresponding radio button in the "Envelopes settings" dialog.

15) Display of the selected statistical parameter on cumulative frequency curves:

For the view of envelope cell histogram, a symbol (red dot or vertical red segment)
indicates the statistical parameter (Max, Mean, CL, Q, KS-d) selected for the envelope
analysis:

* The abscissa of the point (Max, Mean, CL, Q) is the value of the cell shown in the
3D view, positioned on the adequate cumulative frequency curve (empirical for Max,
KS-d and KS-p; theoretical for Mean and CL).

* The length of the segment (KS-d) corresponds to the value of the cell shown in the
3D view, and the segment is positioned between the empirical and theoretical (assuming
normal distribution) cumulative frequency curve.

For the protection histogram, the same type of symbol (red dot or vertical red segment)

can be displayed, but the type of statistical parameter must be selected in the

drop-down list "Param.stat." (See Analysis->Protection->Histogram tab).



